Cannot play today, June 19th, as update is incompatible


#1

I installed the game about 4 days ago and have played it frequently since then. Today, however, when I launch the game and after the loading… and connecting… screens, I’m told there is an update. I click the update button and go to the Google Play Store. The page for the game tells me that “Your device isn’t compatible with this version.”

I’m using a Galaxy S7 Edge, with Android 7.0. I’ve no idea the current version of the game on my phone

Any ideas? What other info would you need from me to help work this out?

Regards,


#2

Hello Maculatus,
If you haven’t already done so I recommend that you send this information to https://smallgiant.zendesk.com/hc/en-us.
This a job for the tech folk with the company. :slight_smile:
Good Luck!


#3

Will do. Good to cover all bases :slight_smile:


#4

It will just put you in touch with the right people faster!


#5

Ok, I know it’s been a while since this thread was active, but wanted to say that I’ve had the same problem for 6 months. And after no. 3 APK download - because I still couldn’t update the game - I stumbled upon a solution that apparently works for me.
I live in Denmark and my Galaxy s7 edge is set up as such. But I wanted Google Assistant and to do that I had to 1: change the phones general language to English (us) and delete all other languages 2: clear cach for the Google app 3: clear all resent apps.
The phone almost choked with all the new settings it had to reset in the back-ground, but after a while it worked fine again, and Google Assistant was there. And apparently it now can update Empires and Puzzles.


#6

So…feeling a bit stupid right now but just figured out what was wrong with mine.

Running a Galaxy S7, none of the above worked but the fix in my case turned out to be simple.

Galaxys have battery saver on them, battery saver can lower screen resolution to save power.

My battery saver lowered the screen resolution to below minimum spec, as soon as I turned this off or plugged my charger in…what do you know, no longer incompatible.

Feeling slightly silly, but hopefully this helps someone out there


#7

Thanks for offering this solution! :slight_smile: Just to make sure, did you perform these steps or did you solve this some other way? Just making sure so we can update our FAQ with the solution.

Reset Your Device Resolution

On some high-end Android devices, resolution might cause a device to appear (incorrectly) incompatible.

Go to Settings, then Display and finally Screen Resolution
Reset your resolution to the maximum setting.