Cannot log in - requesting update

1 Like

Approximately 9 a.m. EST (New York). Attempted to open the game. Pop-up I can’t close say update available. Click on link to Google Play store. Only options available are “Install” or “Open”. Game is already installed. Click open goes to game, with pop-up informing me update is available. Assuming the update fixes the loot ticket bug, but I can’t find out.

[Moderator edit to rmove SS with Account info]

It happened with me again in the bluestack app

Same ploblem…plus some weird anomaly

Yeah…and deleting the instance and installing from scratch doesn’t help…after installing it says there is an update. Why would they have an old version for people installing the game for the first time?

me too ;/ …;/
eh

here is normal again :slight_smile:

There is another thread with this same issue. Been trying to reach their support though the Play store and won’t allow me sign in. Terrible support.

I have tried unmounting the sd card and doing reinstall.
Did the clear data/cache

The support page has the below info. I am not clearing my entire phone just to have this not be fixed.
Clear Apps Cache
Go to Settings, then Apps and finally All
Select Play Store, then Clear Cache & Data
Select Empires & Puzzles app, then Clear Cache & Data
Try updating the game again

Unmount SD card
Go to Settings, then Storage and finally Unmount SD Card
Try downloading the game again
Re-Mount SD Card by Navigating to Settings, then Storage, then Re-mount SD Card

Reinstall Google Play Store
Go to Settings, then Apps and finally All
Select Google Play Store, then Uninstall Updates
Try updating the game again

Make sure that power saving mode is not enabled

  1. Navigate to Apps > Settings
  2. Tap Search, then search for and select Power saving mode
  3. Tap Off.

Reset Your Device Resolution
On some high-end Android devices, resolution might cause a device to appear (incorrectly) incompatible.
Go to Settings, then Display and finally Screen Resolution
Reset your resolution to the maximum setting.

Please make sure you have connected your game to Google Play before trying to reinstall it. For more information please check out Save your progress with Google Play! (Android)

:grimacing: terrible

Remain calm.
Whenever there is a problem like this, I don’t get all freaked out. It usually means there were other glitches after the initial rollout. I check here, check on Line (discord or whatever you use) and try again several hours later.
As a leader I always check here if any of my guys don’t check in during war, to make sure there are no problems. (We have all been playing daily for years, but a couple still don’t have outside the game chats) And if there are reported problems, I know it will be fixed shortly.

1 Like

Not freaking out, but if nobody reports an issue, it may not get fixed. I’d have reported it in the app, but the issue didn’t allow it.

In my experience this is usually resolved when they do the forced update…but in this case maybe that has already happened?

For those using bluestack - I deleted the instance, created a new one, went into the android settings in that instance ->apps->Google Play and cleared all the data. Then searched for Empire and Puzzles. The clue that it would work this time was the icon for the game was no longer the Halloween icon. Installed it and it worked.

Edit: Only do this if you can remember your google play account information, you will need it to log in.

I cannot enter in my account neither with bluestacks or other android mobile phones. Lost 6 war flags, titan …TOL and who knows what else! What is going on? Why nobody of SGG staff is not answering to this issues? I will tell my team leader to kick me out of the alliance.

Thanks a lot SGG!

Still no update for my device - OS Android 6 - can’t enter the game

Same problem, Android.

Since yesterday that a player from my alliance cannot enter, how is it possible that every time a new update is launched this happens, she says that there is an update but there is nothing

same problem, can’t enter game
[Edit to remove personal account info]

what annoys me most is that i was unable to login when expected and in the chaos was not able to get logged in on time to complete the Shiloh Desert rare quest (only had the last level to complete). With the near impossible task of acquiring 4* mats in the game, this is a HUGE blow. Watched the darts go down the drain. smh…

It’s been two days now. Not about freaking out. It’s about getting some sort of response. I can’t even communicate directly through the play store as it asks me to sign in and doesnt even offer a way to setup an account. Maybe I am missing something. Or maybe it’s just the terrible support.

1 Like

Cookie Settings