Cannot log in - requesting update

I have the same problem too… there is no update in App Store and I cannot log in to the game!!!

Same here no update for iOS. App Store just says open. It is stuck like this for more then 15h now.

@Petri , @KiraSG , @Guvnor , @Staff_SGG

[Mod edit: removed as with account identifier]

Same issue on Ipad, There is no update at AppStore.

так же переустановил игру и не могу теперь зайти требует обновиться

Unfortunately I’m not staff so I can’t help with this.

Usually updates and availability/ rollout are control by Apple / Google stores.

You can try contacting support but not sure if they can / will be able to help.

Check out their support website tho as it may have some other information:

I cannot log in to the game. There is a message that there is new update but there is no new update in App Store…

Guvnor, please, if you can report this issue to SGG staff. We have a war today…

I am also having this issue. Tried on two different Android devices and both say update available but no update available. Please fix!!!

I tried the fixes from this site they suggested for my android but non of that worked.

Hello, same issue here, can you Guvnor send a ticket to Empire’s support team? Developers or someone?. Today we have war, and 2 of our members for now cannot access their accounts due update issue, this issue is encountered on Samsung Galaxy s10, android affected, as we can see iOS affected two… This is a major bug, maybe rescheduleing the war will be an option.

More than this, for this kind of issues SHOULD be handled as high prior due the fact that they are critical.

In terms of the App Store (iOS) this appears to be a common sync problem. It occurs when devs release upgrades for both iOS and Android as the approval process for iOS (App Store) is much more stringent and slow than the Google Play Store. Uploading to Play Store literally takes the devs 2 minutes to complete. App store is usually 24 hours upwards to 3 days.

This does not speak to the people having Android issues (I for one had no issue updating in the Play Store right away). As for the iOS version, it looks like it is waiting on Apple approval to be “live” in the App Store which leaves everyone on iOS SOL.

What I am surprised about is that generally devs would wait to upload to Play Store until it clears App Store so syncing is generally just a few minutes as opposed to having no idea and getting this concurrent sync issue.

Furthermore, your “customer support” is nonexistent. Thanks to @Guvnor (seriously, I mean it!) for trying to cover for the lack of customer support but your website essentially points people back to this forum when they have issues and it appears there is no real regular monitoring of bugs and issues here. Otherwise, this would have already been fixed (or responded to in some form).

I love you E&P but be better! If you mess up people’s war attacks/titan hits/etc. because you can’t do a better job of syncing across platforms you will lose even more players than the already hemorrhaging amount as of now.


1 Like

I play the game on multiple devices. Two out of the three are having the issue.
If it wasn’t for my third device I would be missing my alliance war.

Can someone solve this problem??? There is no update available in iOS…

Is this likely to be fixed in next couple of hours? War and Titan hits to do and chests to fill

There is no update in App Store and as a result I cannot log in to the game!!

1 Like

Approximately 9 a.m. EST (New York). Attempted to open the game. Pop-up I can’t close say update available. Click on link to Google Play store. Only options available are “Install” or “Open”. Game is already installed. Click open goes to game, with pop-up informing me update is available. Assuming the update fixes the loot ticket bug, but I can’t find out.

[Moderator edit to rmove SS with Account info]

It happened with me again in the bluestack app

Same ploblem…plus some weird anomaly

Yeah…and deleting the instance and installing from scratch doesn’t help…after installing it says there is an update. Why would they have an old version for people installing the game for the first time?

Cookie Settings