Cannot enter the game use cellular data

after updating I can’t enter the game if I use cellular data but if I use wifi I can log in, are these bugs? this happened to all members of my alliance too

1 Like

Same with me…

1 Like

Hi @Ichigo and @CiuPekTong

The fact that 3G or 4G cellular connection is sometimes not strong enough to download new assets for the game. A weak or unstable network will result in many crashes and the inability to run the game as seen. Please kindly keep in mind that once the asset bundles are successfully downloaded, you should most likely be able to play normally with your cellular network.

In other words, whenever you see that “There was an error communicating with the asset server” pop up, please connect to your nearest wifi network and download the asset bundle before proceed to play normally with your own cellular network. However, we recommend playing over wireless (wifi) connection.

I hope your problem will be solved from now on.

1 Like

can someone help me? I want to ask since last night upgrading v18.01 I can’t play empires through mobile data. and this happens to all my members who use the same mobile data brand as me, but if I use wifi I can easily enter. to this day I still cannot enter the game through mobile data. then I tried the turbo vpn app and made it in. I want to ask this is an error from my provider or from SG because we know the app that uses VPN is a blocked app. sorry if this is out off topic but this really annoys me

Ichi i wish i could help but i have no clue

Posting in errors/bugs will probably catch more attention though

Start a new thread there

I have tried it and I have also tried sending a ticket but I got an unsatisfactory answer for the solution :sweat_smile:

i have the same problem…i cant proceed at maps!

@hafiq I think this is actually a more specific error, here’s what the staff had to say about it:

(@Kerridoc @Rook @Coppersky this post should perhaps be split, and the account number in the screenshot needs to be cleaned off)

1 Like

Please scroll up for Solution from Na.Na above. :slight_smile:

If you still have issues, please contact Game Support:

Cookie Settings