Cannot Connect on WiFi

Is anyone else seeing an issue where they can’t connect to the game (gives network error) ONLY on WiFi? 4G connection is fine. No other apps/games have this problem on the same device so it’s definitely limited to Empires.

Tried putting the device in the DMZ on the router, just to see if it was a port issue.

Tried restarting both the device and router. Same problem.

Also, I was playing earlier today on the same device without any issues.

Update 12/4: This is still happening today although the game was working fine earlier. Connects to Google Play but won’t load the game.

Update 12/9:. Obviously this must just be me, but the problem remains. I have yet to find any other app or web site that doesn’t work, except E&P, one WiFi. Tried everything from turning off the router firewall entirely too reinstalling the game and nothing fixes it. Any suggestions at all out there?

Nope not just you I have 2 others on my alliance with the same issue. Why I’m here now cause they cant log on. When they can log on it’s very sketchy through wifi. They get logged out almost immediately. They both live in the state of Maine of the USA…

1 Like

I think Maine in particular has been having electricity issues lately that may also be affecting their Wifi.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings