Cannot buy latest 1.99 offer

#1

Cannot buy £1.99 Offer for gems

1 Like
#2

Sorry it’s the latest challenge offer £0.99 for 200 gems have tried all morning but keeps saying try again later

#3

Please try restarting your game, that should help!

2 Likes
#4

Also did it stop u right away or like on the 2nd or 3rd? I only ask because some credit cards or bank debit/credit cards will lock on back to back identical dollar amount purchases especially if dun quickly. If that’s the card I suggest calling said financial institution and they will clear it right up. Just brainstorming to help u with ur problem. Best of luck

#5

That sounds like a bank/credit card hold. Seriously I bet if u call the company behind ur card they will b able to clear it up

#6

I have been unable to purchase the even $.99 gem offer all day. Keeps saying there is an error and try again later.

1 Like
#7

I am having the same problem. I was able to purchase one earlier today. Now I get a message “Purchase in progress” then nothing happens. No error message, no nothing.

#8

I’m having the same problem. I already bought the offer one time but now I can buy anymore. A message showed up that said that I already own it.

#9

#10

Welcome too. I didn’t know it was ur first post. How did it work out too?

#11

Welcome to the boards and also have u considered calling ur bank or credit card company depending on what u used? Normally no matter what the problem they will b able to go back to the second u tried and it didn’t work and fix it. If u get a newbienon the phone actually ask for Security and Fraud. Clear that right up! Promise.

#12

I’ll just put this up for @Kevarcen, @Sambuca and @javier0719. I’ve been in banking and in the field of risk mitigation and loss as well as AML for well over a decade and like most got started in fraud. I can honestly tell u that I’d this was an in-game issue the whole forum would b blowing up. I would stake the unopened bottle of PVW
20 1999 I have on my rack in the basement that a quick call to ur financial institutions will fix this. And the example of what in would stake on this is being used in a fasciitis manner. Don’t thinkmur getting my 20 yr old cellar aged Pappy in the chance I’m wrong. Cause well I have been like 3 or four times. :wink::grin:

#13

I do tend to agree that it is not an in game issue. I feel you are correct that many, many more would be jumping in. I will be contacting my financial institution today and maybe Apple support as well. Wish me luck. Thanks for the welcome and advice.

#14

Anytime. Also calling bank first is always the proper order because if u still need to call apple saynif they double post it all
Of a sudden u have a disputed transaction on file with ur bank and ur rock solid. U can always shoot me a message @EVA01 if u ever have transaction questions. It’s literally what I do. I monitor regular and irregular transactions and help implement regulations and r own systems to make purchasing easy but also safe. Tuff tightrope act lemme tell ya!

#15

No, I believe you owe me a bottle of wine. It’s a bug. The system doesn’t even attempt to make a purchase and no purchase is made. The “purchase in process” message flashes only briefly across the screen. It doesn’t take one to the pay screen. It just hangs on the image of the glittering gems for $.99.

closed #16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.