Can’t login due to update

Since yesterday I’m trying to log in unsucessfully.
When logging in an update warning pops up and redirects me to apple store.
At apple store there’s no update, only open game option…
Then I get myself in a loop !!!
I have updated my iphone to last iOS and no game update at app store.
I have tried to erase and install the game again but it’s still the same and I think I have lost my account because I now have a different account number.!

[edited by SG staff - account details removed]

1 Like

FYI the forum users are E&P players just like you. Personal account information should not be shared here.

Instead contact SG direct by submitting a support ticket. GL

1 Like

Two playes in my alliance cannot log in also. This is an update error

My wife is having the same problem on Android. Seems to be local to her phone too as I can switch to her account on my phone. She has tried uninstalling and reinstalling with no luck.

And BTW…the only way to contact support being in-game is a pretty short-sighted issue here!

1 Like

All I think of a resolution is to buy a new mobile phone :blush:

Hi @xicobombas,

Do you, by any chance, play on 2 different platforms? In other words, do you play on a smartphone and also play on a tablet?

I’m only asking because my alliance teammate is having a similar problem. :thinking:

What about you @Niku? @HostileOx ?

Kerrang

Yes, my wife does play on phone and tablet.

1 Like

I used to play on 2 cell phones and in different platforms.

New update is now available at app store and I can play now again.

1 Like

Still an issue here, not possible to log in. Sends me to update, but no update available. :thinking:

Same error here. It says there is an update available sending me to Google Store. While at Google Store it says there is no update available. Impossible to enter in the game.

Don’t use the update link from the game. Go manually to Google Store and search for empires and puzzles game. Once you found the game click on update. It works for me.

I have tried both ways.
On Google Store there is no Update version. Just Open or Uninstall.
Have uninstalled, same Christmas version opens with the new installation. Requests to update again and again with no option for that.

I really have tried everything that has been recommended. But no solution - still unable to log in :confused:

Same issue like the rest; I get told to update, sent to the store, but no update to be found.

Had same issue. At store search ep, clicking open should redirect to update, hope it helps

Thanks for your hints.

Available version at the store: 34.0.2 build XXXX

It should have version 35 not 34, that is the problem.

Is there any other option to have the latest on the store?

Have you tried to delete and restore the game completely.?

@MissCat I have uninstalled it… but it won’t change nothing as the current available version at the store is 34.0.2… it will always install 34 and inform there is a new version… is there a way to pull the latest version in the store? It says 23Fev2021 instead of the new 29Fev2021

Settings - Applications - Play Store - clear cache and data. Then open the Google play app and check the update of the game please. In this way, Google Play will be like newly installed. I think your problem with game update will be solved :slight_smile:

1 Like

Went to the store and the new version was there without that cleaning but thanks for that @MissCat.

On a next time I will remember that step for sure :wink: You deserve an Uraeus this month, will send good vibes for you to have him :slight_smile:

Cookie Settings