BUGS with Valentine’s Day Offer (NO FEEDBACK)

#1

If you have any issues with the Valentine’s Day “Share the Love” offer not functioning properly, post them here.

If you have feedback on the offer, please DO NOT post that here, and instead post it in this thread:


If you have issues specific to your account, please contact Support, as no one on the forum (staff included) can address account specific issues:


If you made a purchase and didn’t get your order, please check these instructions:

1 Like

#2

I had 2 of my alliance members that send the gift in the same time and we got only one gift from only one member

0 Likes

Valentine’s Day Offer – Share the Love! What do you think of this?
#3

I did it once and receive an error. Tried again and said I already bought it and gave me the gems. The message was there too on the chat.

0 Likes

#4

It also appears to me that I bought it but I have not received the gems and the message has not arrived either

0 Likes

#5

I’m pretty sure I didn’t get the gems from one of my alliance members who bought the deal. It also happened in my other account where I missed getting it from one member as well. On both occassions there was no message in my inbox although there was a notification in chat

0 Likes

#6

Everyone is my group got gems and I only got them from 2 people. I have one other account and I got them from everyone so it was a total of 9 people I believe. But my main account only got them from two. Where are the rest. Everyone said they got the ones I sent out.

0 Likes

closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes