All Heroes doing only 1 point of damage ONLY during Atlantis Rises, only in Season 2: Province 6, Stage 1

I am posting this here, because I could not find a similar problem as mine anywhere.
I cannot post a screenshot, as my phone does not have this capability (it’s my work phone, and taking screenshots, and using the camera have been disabled, for security measures). So DO NOT , I repeat DO NOT ask for screenshots.
Cannot participate in Atlantis Rises, my heroes die in the first round of province 2. The problem is that my troops (epic troops, level 5 all of them) do only 1 damage (as if all my heroes are missing), therefore my heroes are killed in the first round (first move even) of province 2, Concordia Riverlands, level 1.
My heroes are Bane (fully ascended, talents level 4), Kiril (level 2.45, or 45.2), Gadeirus (level 2.35 or 35.2), Graymane (fully ascended, talents level 4), Renfeld, level 2.22, Jahangir, level 2.22, Belith fully ascended, Gill-Ra, level 3.2. I have checked, this only happens in province 2 Concordia Riverlands specifically, not on other provinces, raids or Titans. And it so happens to appears right as Atlantis Rises started ? I also tried different hero combinations, but the result is the same, only 1 damage, regardless of the hero.

Sometimes troops get dropped after some war battles. It is imperative to double check your troops on each hero before any war starts. It’s also good practice to check your troop levels for each hero in a team you are using a war energy flag for. You can use the same troops across heroes of the same color that are on different teams, but you probably knew that already.

Hi, I have checked my troops, as a matter of fact, before going into season 2 Concordia Riverlands, level 1 the second time, since the first time all my heroes were killed right in the first move. Still epic troops, level 5. Also, each hero has its own troop.
What is strange is that this bug, or problem, happened right as Atlantis rises started, and…everything is working fine since Atlantis rises stopped. So I could not participate. That’s the problem.

I understand. That shouldn’t happen. I think reporting that issue is all you can do, but you will want to try to figure out a way to get pictures to show tech support even if it means taking a picture of a picture on a screen.

@Jocelyn1 didn’t talk about war troops, it was posted in the wrong thread because no other thread about it exist, while at the same time, new forum member do not have the permission to open a new thread in the beginning…

Maybe the moderators can help by creating a specific bug thread. @zephyr1 @Rook @littleKAF @DaveCozy


I moved the posts to a new thread, thanks for the heads up!


Concordia Riverlands is Province 6 — did you mean Province 2, Anchor Beach, or Province 6?

Did it work previously on that Stage, before Atlantis Rises started?

Were other Stages affected?

Since Atlantis Rises started, you’re seeing normal damage from your heroes now?

You mean you literally made one tile match and then all of your heroes died? Or do you mean you died while facing the first wave of monsters?

This sounds like hard difficulty

difficultly normal is 6 we
During Atlantis Rising difficultly hard is 7 we

I often have trouble fighting the wrong difficultly so I carefully check during Atlantis Rising.

Possibly the OP is accidentally doing hard difficultly during Atlantis Rising.

Concordia Riverlands is Province 6

Have you tried doing Privateer Cove ( Province 1 ) both before Atlantis Rising and during Atlantis Rising.

Before Apple added screen shots, Gryphonkit ( my wife) or my friends at work, would take a photo of my screen with their smartphone and send me the photo.


@zephyr1 I expressed myself wrong.
It was in Season 2, Concordia Riverlands (sixth province, level 1 in that province).
I have played the other provinces until that one. Normal level/stage, btw, not hard.
No other stages affected, and this happened only as Atlantis Rises started and it doesn;'t happen anymore as it has finished. I am, currently, at province 7, and have passed through province 6 like “through butter”.

I mean at the first tile move, troops made only 1 damage and immediately after my heroes were killed by suspiciously extremely powered monsters.

1 Like

It was normal difficulty. I could not do hard since I was not able to play province 6, Concordia Riverlands, at all. As far as I know, you have to complete the normal difficulty to be able to do the hard one.

Well, good to know, for the future. I admit I did not think of this at the moment.
Unfortunately there is no point in taking a picture or video of the bug/problem since it doesn’t happen anymore and I have no way of reproducing it.



I think the title should be changed.
It was Season 2, province 6, Concordia Riverlands, stage 1 of that province.

1 Like

Thanks for the clarifications! I’ve updated the thread title accordingly.

This is a really bizarre bug that I suspect will be almost impossible for us to track down as fellow players — and it’s definitely the first time I’ve seen someone run into something like this and post about it.

I think you should submit a Support ticket too if you haven’t already. I’m not sure if they’ll be able to investigate the logs at this point, since Atlantis Rises ended a few days ago already, but it’d be useful to have it on file at least as a start.

Instructions for submitting a ticket are here: How to Contact Support (v1.9.7 onwards)

I’m fascinated whether you’ll run into something like this again next month. :thinking:

What is the team you brought? Tiles you don‘t have a hero of will do 1 damage

2.6-1N is a regular stage. But maybe it was 2.6-3N

2.6-3N is a Magic night stage ( normal/ matching/ tile/ physical damage is 50% ) so weak color normal damage does 25% versus neutral color normal damage in a not Magic night stage.

(What Is Elemental Damage? - A Guide to Elements)

Or it could be the missing hero issue caused by costumes

([Bug? Intended? Definitely Issue] Costumes on teams leaving unexplained holes in trial / class quest teams)

1 Like

I had one hero for each color : Bane (yellow), Kiril (blue), Gadeirus (green), Renfeld (purple), Jahangir (red).

It was that.

Bane is the only hero in my teams that has a costume, and was not equipped.

Thanks for the updated title !

I will be surveying if this happens again (not only during Atlantis). I unfortunately am not going to submit a ticket this time but will do if or when the bug happens again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings