After update - still asking to be updated- second Android device will not update

I tried the things listed in the “can’t update android” page. It still says “you have a new update” and when you click on that and go to store it only has uninstall and open as a choice. Last updated is listed as May 29th…so its confused. On my other device it is last updated on June 10th and everything is working.

Any thoughts? What is the implication if I remove the game from one device and reinstall?


Are both devices compatible?

I run Empires on two apple devices. Once I update on one device, I have to update the other device.

I make sure to update my iPod ( iOS 9 ? ) first because eventually Empires will not run on it. Then I will have to decide between replacing it with a newer device or just playing Empires on a single device.

( Discontinuing Support for iOS 7 (Temporary Fix Released) )


I do not know how the Android partial roll out works, but you may have to download an APK to get the latest version on both devices especially if they are linked to different Google Play accounts.



Both are compatible and I have had no problems prior to this. Both have the update ready. I may see if my third device works…but I don’t want to complicate things further.

They are linked to the same google account…

1 Like

Any idea on the impact, if any, of uninstalling on one device. I think I remember SG warning that you could lose all progress if you remove the game, but I think I also remember someone doing it and it all being ok…


IIRC you only lose your progress if it is not linked to your Game Center profile/ Google account. But I am not 100% sure.

Force update

On iOS, when I want to force an update on alliance chat, I first remove some recruits from Extra low cost training - to ping the server - then do a forced restart of the app - to reload the chat.

I would at least do something similar to make sure your working device is updated on the server.

Log out

Does android let you log out?

1 Like

There’s no warning like this on the support website that I can find. I think if your game isn’t linked to Facebook or the appropriate Apple or Google account, THEN deleting the game will lose you all progress.

Of the app, or of your google account on the phone itself?

1 Like

Log out

Which is this?

Re-install/ lose ALL progress

For re-installing/ lose ALL progress.

In theory, you can reset your progress by deleting and then re-installing the game. However, if you are using Game Center (on iOS) or Google Play (on Android), your previous progress will be automatically recovered. ( linky, linky )

Do not delete

This appears to only apply when you cannot update, but it does not mention in which circumstances. It is possible the “lost progress” is only since the server was last pinged. Would suck to lose a 5* 1.1 Gravemaker.

So it sounds like losing some progress is possible if you run into an update problem, but losing ALL progress is not possible.


Just of the app. “Log out” = close the app. I’m old enough that all online activity requires “logging on” and “logging off” in my head :slight_smile:


This is from an older version. The v22 release notes don’t contain this warning, interestingly enough.


Well I uninstalled and reinstalled on that device. Good news is all progress was saved. Bad news, it didn’t fix the issue…hmm


I’ve heard good things* about spinning around widdershins three times too.

* “good things” as in it’s highly unlikely to erase your account too


Shooot I went clockwise…20 bad omens.

1 Like

Having the exact same problem.

Well I’m hoping that when they push the forced upgrade it will fix the problem…but since I have two other devices I’m not too stuck no matter what…Hopefully you have options too…

When I launch the game on my phone, it says “Update Available” and does not let me continue.
But when I click “Update”, it goes to the shop, and there is no new version (options are Uninstall and Open). I am not sure if it is a good idea to post my account number here.
Version installed is v21.0.2, I cannot read the build because of the round corner of my phone.
Uninstalling and reinstalling did not help.
Android phone Huawei.

I have the exact same issue with same phone

Android is now on version 22 but question is to do with Huawei?

1 Like

i have two seperate gmail accounts and naturally two 2 play store accounts on my lenovo k6 power. Everything was flawless until last update yesterday 11.June.19; when I tap it to open opening screen prompts update, after tapping it play store page arrives and no update notification occurs. Only open and remove commands exists. When tapping open it goes back to the same connecting screen with update prompt again. Cache removed, last played account tried several times, installed again, deleted updates tried everything E&P suggested for former update issues like this one. Please help. Thank you in advance

Interesting. I posted the same problem in the general problem, and I was not the only one, but we both had Huawei phones.
I assume you have a different brand?

I have a Huawei mate 20

Cookie Settings