Advent Calender gone?

After todays update for Android to version 1212 there is no more advent calender in the game?
Is this intended or is this a bug with the new update?

Already reported -> No winter offers

Actually yours was first, I saw later :joy:


No winter offers. On my base page

And probably your shop is not available either. Old issue, for years and SG staff said will solve this. Maybe in 2030…

Only by clear cache of the game, clear cache of the play store, clear cache of Google Play and restarting the phone will bring these offers on your screen. But they will be available only that online session. Next time you go online, the offers won’t be there.

And the support is completely useless, like usual… If you open a ticket, the answer is their troubleshooting page for this kind of situation. Given solutions that never worked.

I struggle for months to find one. I still do not find any difference in any setting between my phone and my tablet (one device doesn’t show the offers and the other one does).

My calender didn’t disappear but it said “claimed” and I was playing my game at 1205a.m.

The calendar doesn’t necessarily change at midnight. It is at 07:00 in my time zone (UK GMT)

Have you checked that your in-app purchase settings are up-to-date?

1 Like

I compared my Android phone with my Android tablet in every single setting. The phone doesn’t display any offer and the shop is not available (old issue, I know). Anyway, the weirdest thing is absolutely all settings for everything, are the same.

I managed to find out the problem though. It is the Play Store. I emptied only this app cache and restarted the phone. And then the offers appeared, shop is available. I actually bought the winter offer with the 50 + 50 emblems, to see if is any problem with the payment method or anything related to it. Obviously, is not; it worked. And all the settings are identical with my tablet, like I said, which works perfectly.

Still, after I go offline and go online again, the offers don’t appear anymore and the shop is not available. Yes, the Play Store is up to date… I really don’t understand what is going on… Why some Android devices work and others not, since all settings are identical? Hmmm…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings