Ads are broken

Continually getting broken ads that don’t play correctly and cause the game to hang. is this happening to others?

3 Likes

Yes, this happens to me too. Click on the ad, the game will crash completely. Android emulator BlueStacks OS, Version39.0.0 Build 1542

1 Like

It happens to me, but only with ONE specific ad: Match Ten. I posted about it elsewhere yesterday, but just wanted to confirm here that I am affected.

Seems that every other ad I’ve seen goes fine, just this one specific Match Ten ad that hangs and crashes the game.

Me too. I don’t actually get to see any ads. Game just crashes.

Happening to me and my hubby, too. We get the ad, it freezes and we need to close the game. Today my hubby had to close the game 4 times in a row before his ad worked.

Same here or close. It seems it may be something to do with “Google Play games”. E&P loads, then ads appear (I can click on the X to clear them until “Google Play games” loads), then E&P app freezes. Started shortly after last update. I’m on version 39.0.1.

Mine seems totally broken now. I’ve tried 9 times but the ads just freeze. I close the game each time but it still isn’t working.

The 11th ad also froze but at least it was far enough along that I was able to get the rewards. I’ve submitted a support ticket.

Mine let’s me watch the ad (on iOS), but when I X out of it it doesn’t give me a reward. It’s happening on both my phone and iPad.

Mine’s been doing it now for the past hour and a half. needs to be fixed

It’s still happening on both my tablets and on my husband’s as well. We are using the tiny ! in the upper right corner to hide the frozen ads. Sometimes it takes 9 tries (closing the game after each time), but so far we are eventually getting a working ad.

I did put in a support ticket but unfortunately the recommendations weren’t helpful. Considering it seems to be happening with only specific ads, I don’t suspect it’s an issue with my tablet, and I can’t see how reinstalling the game would help either.

I just had to close my game 8 times again. It’s always the same ad types that are affected - the ones with the progress bar running along the bottom of the screen. Occassionally one will work.

The ads that show timers running down don’t seem to have the issue. Because it seems to be ad-specific, it can’t just be something happening with my tablets, or my husband’s tablet. To me that wouldn’t make sense. I’m just hoping that by hiding the broken ads, eventually I’ll find a few that work.

Read that the bug issue with Avalon ad was fixed, tried 10 min ago and still not repaired. So no rewards again

1 Like

Still happening to me, mainly with the State of Survival ad…

With Bluestacks happens, but with NOX didnt in my case. Just must wait for maybe 3 sec to load the ads.

“No ads available, check back later” all the time for 2 days now. Happens on android phone and emulators. This thing never works.

Tried resetting google ad id on all devices, nothing helps.

1 Like

A lot of people are also complaining here about the same topic, seems you are not alone

I was having no ad available issues starting last night, rebooted phone, closes and opened app nothing was working and again this morning. I did get the ad to work after taking my phone off WiFi, for some reason on wifi the ad would not come available.

Also not getting rewards. Have been watching the entire ad through and then it closes and says no ad available. Refresh the game and force close etc and it repeats. Has been happening for 4 or 5 days now. I think I have gotten one reward in the last couple days despite multiple attempts.

2nd consecutive mystic vision without any loot due to ingame popup ads.

:face_with_monocle:

1 Like

This is still happening @Petri . must have tried to do MV 15 times today. State of survival ad hangs for 30 seconds then plays but no rewards, just says “ads not available come back later”.

Cookie Settings